replicateBE: error in data input [🇷 for BE/BA]

posted by thalita_m  – Brazil, 2022-09-17 07:28 (528 d 07:44 ago) – Posting: # 23303
Views: 1,718

Hi Helmut!

First, as stated by roman_max, thanks you, Michael and Detlew for all efforts in this package!

So, I am dealing with some troubles when I run the methods A and B in the package to analyse a pivotal study and calculate CVw

I prepare my datafile as descripted on "DataStructure" in help(p=replicateBE) and save as a CSV: subject, period, sequence, treatment, PK, logPK

Following the example of GitHUB, I am using the code:

cabo <- read.csv(file="Cabo_Outcome.CSV", head=TRUE, sep=",")
cabo
   subject period sequence treatment        PK       logPK
1        1      1     RTTR         R 23017.637 4.362060731
2        1      2     RTTR         T 26945.375 4.430484232
3        1      3     RTTR         T 27755.074 4.443342393
4        1      4     RTTR         R 23901.877 4.378432006
5        2      1     TRRT         T  7715.025 3.887337332
6        2      2     TRRT         R 21282.365 4.328019892
7        2      3     TRRT         R 13603.772 4.133659359
8        2      4     TRRT         T 11700.822 4.068216383
9        3      1     RTTR         R  8982.120 3.953378859
10       3      2     RTTR         T 21978.182 4.341991758
11       3      3     RTTR         T 13025.147 4.114782649
12       3      4     RTTR         R 13487.560 4.129933376
13       4      1     RTTR         R  4821.158 3.683151339
14       4      2     RTTR         T  8817.647 3.945352731
15       4      3     RTTR         T 12828.745 4.108184177
16       4      4     RTTR         R  9775.555 3.990141410
17       5      1     RTTR         R 18677.973 4.271329735
18       5      2     RTTR         T 27177.154 4.434203980
19       5      3     RTTR         T 15267.030 4.183754567
20       5      4     RTTR         R 25284.525 4.402854806

res <- method.A(verbose = TRUE, details = TRUE,
                print = FALSE, data = cabo)

Error in if (!act %in% ref) { : argument is of length zero


If I try to run the dataset DS01 it works perfectly.


I'm not so experienced in R, I'm just a begginer. Your advice and help would be of great value!

Thanks in advance!

Complete thread:

UA Flag
Activity
 Admin contact
22,912 posts in 4,806 threads, 1,635 registered users;
28 visitors (0 registered, 28 guests [including 5 identified bots]).
Forum time: 14:12 CET (Europe/Vienna)

It is the peculiar and perpetual error of the human understanding
to be more moved and excited by affirmatives than negatives.    Francis Bacon

The Bioequivalence and Bioavailability Forum is hosted by
BEBAC Ing. Helmut Schütz
HTML5