Bioequivalence and Bioavailability Forum

Main page Policy/Terms of Use Abbreviations Latest Posts

 Log-in |  Register |  Search

Back to the forum  Query: 2017-06-25 05:35 CEST (UTC+2h)
 
yjlee168
Senior
Homepage
Kaohsiung, Taiwan,
2017-06-07 22:02
(edited by yjlee168 on 2017-06-08 18:55)

Posting: # 17459
Views: 429
 

 bear v2.8.3 running error under OSX with RStudio [R for BE/BA]

Dear all,

If you still have the error or similar errors when running bear under OSX (Sierra) with RStudio (with current version 1.0.143), you can try one of following steps to solve the error.
  1. Just run bear with terminal. This is the most easy way to solve the problem. If you have to run R with RStudio, please see the next step.
  2. Before running bear under RStudio, maximize the window size of Plots panel first. Also do not place any window on the Plots panel. Keep it as clean as possible. It is quite sensitive. Otherwise, it may fail to run. If you still get the error or fail to run, you can try to add one more line after library(bear):
    options("device" = "quartz"). This will enable bear to plot with X11 graphic device, not RStudio graphic device (RStudioGD). What you loose as is not able to browse the plots on Plots panel backward or forward (I like that function very much too, but...). I will use the code for next release. One more thing to remind is not to close the plot window; otherwise, you won't see the plot for the following run. You have to 'Restart R' session from 'Session' of the top menu of RStudio or just press (ctrl+shift+F10) to fix this problem. However, no error occurs. Where does it plot? Space where no man has gone before? In Ubuntu/Linux or Windows (10), the plot window will show up again.
That's it. Thanks for reading.

All the best,
---Yung-jin Lee
[image]bear v2.8.3:- created by Hsin-ya Lee & Yung-jin Lee
Kaohsiung, Taiwan http://pkpd.kmu.edu.tw/bear
Download link (updated) -> here
CECIF
Junior

Colombia,
2017-06-16 18:28

@ yjlee168
Posting: # 17494
Views: 274
 

 bear v2.8.3 running error under OSX with RStudio

Hello,
I am haveing trouble with version 2.8.3 on windows.
when I type library(bear) this is what I get:

Error: package or namespace load failed for ‘bear’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 there is no package called ‘randomizeBE’


I have tried reinstalling many times and I am still getting the same message.
Helmut
Hero
Homepage
Vienna, Austria,
2017-06-16 19:16

@ CECIF
Posting: # 17495
Views: 258
 

 randomizeBE missing

Hi CECIF,

» there is no package called ‘randomizeBE’

Hhm, bear should observe dependencies (i.e., automatically download/install required packages). Seems that you don’t have package randomizeBE.

» I have tried reinstalling many times and I am still getting the same message.

The message tells you that randomizeBE is missing. Re-installing bear would not help. Try this before typing library(bear):

package <- "randomizeBE"
inst    <- package %in% installed.packages()
if (length(package[!inst]) > 0) install.packages(package[!inst])
lapply(package, require, character.only=TRUE)

This should look whether randomizeBE is properly installed and – if not – automatically download it from your preferred CRAN-mirror and install it.

[image]All the best,
Helmut Schütz 
[image]

The quality of responses received is directly proportional to the quality of the question asked. ☼
Science Quotes
yjlee168
Senior
Homepage
Kaohsiung, Taiwan,
2017-06-17 18:47

@ CECIF
Posting: # 17496
Views: 221
 

 installation problems of bear v2.8.3 for Windows

Hi CECIF,

It sounds like that you did not install all required packages correctly. Please have a look at this post. Skip Step 1: Java installation because we don't require Java VM any more since v2.8.1. Start from Step 3 & 4. All dependent packages need to be installed manually using preinst.r. Download preinst.r from Sourceforge and place it in your working directory (default in Windows is My Documents). Open R console and type source("preinst.r"). Select 1 for bear and then 0 to exit. After being done with all installation, remember to run R as system administrator for the first time. Then type library(bear) and go(). You will see a pop-up dialogue to remind you installing GTK+ driver for Windows. Just do it. You only have to do this once (until next update of RGtk2 package). Then close R console. And re-run R console again. Type library(bear) and go() to run bear.

For Helmut: many thanks for your help.:thumb up:

» ...
» I have tried reinstalling many times and I am still getting the same message.

All the best,
---Yung-jin Lee
[image]bear v2.8.3:- created by Hsin-ya Lee & Yung-jin Lee
Kaohsiung, Taiwan http://pkpd.kmu.edu.tw/bear
Download link (updated) -> here
Back to the forum Activity
 Thread view
Bioequivalence and Bioavailability Forum | Admin contact
17,003 Posts in 3,644 Threads, 1,041 registered users;
28 users online (0 registered, 28 guests).

Everybody is a Bayesian.
It’s just that some know it, and some don’t.    Trivellore Raghunathan

The BIOEQUIVALENCE / BIOAVAILABILITY FORUM is hosted by
BEBAC Ing. Helmut Schütz
XHTML/CSS RSS Feed