Bioequivalence and Bioavailability Forum 07:55 CET

Main page Policy/Terms of Use Abbreviations Latest Posts

 Log in |  Register |  Search

Difficulties with run NCA in BEAR [R for BE/BA]

posted by yjlee168 Homepage - Kaohsiung, Taiwan, 2017-04-29 19:47  - Posting: # 17282
Views: 4,596

(edited by yjlee168 on 2017-04-30 19:41)

Dear Artem,

Sorry about the delay of this response. I just run bear as you did and did not find the same problem. I know that saveRDS() in GUI can be weird. The error you had was because saveRDS() did not work properly. It failed to save the Dose. You can try following codes under R console:
x<- readRDS("bearGUI.setup.rds")
x
                  Methods                Setting
1               run demo?                      0
2            study design                      0
3   single-/multiple-dose                      0
4       lambda_z estimate                      0
5         trapezoidal AUC                      0
6       BE criterion (LL)                     80
7                     ODA                      0
8            dose (in mg)                     80  <-- is it 'NA' or ''?
9         dosing interval                     24
10                  Tlast                    120
11                   pAUC                      0
12             pAUC_start                    121
13               pAUC_end                    128
14         indivDP_output                      0
15 drug plasma conc. unit                      1
16       is a metabolite?                      0
17           x-axis label Time after dosing (hr)
18           y-axis label     drugX plasma conc.
19         analysis types                      0
20       data file format                      0
21              Tmax_stat                      1

If the dose is 'NA' or '', it means that saveRDS() fails to save the value. Why did this happen? I don't have a clue right now. You can try the following steps to see if the error goes away.
  1. delete the set up file (i.e., bearGUI.setup.rds) from your working directory. And run bear again; If this still cannot work correctly, please try the next step.
  2. run the following codes under R console without GUI:
    library(bear)
    require(rChoiceDialogs)
    x<- readRDS("bearGUI.setup.rds")
    x<- edit (x)  ### correct (edit) the dose and other parameter values if necessary
    saveRDS(x,"bearGUI.setup.rds")           ### save your setup
    xxdf<- "";psdp<- ""                      ### leave the line as it is
    xxdf<- rchoose.files(filters="*.csv")    ### supposed that your data file is a csv format
    go2menu(xxdf,psdp)                       ### leave the line as it is

    If this step still does not work (it should, I have already tested), please install the previous version of bear (v2.7.7) if you need a quick solution.
BTW, could you please tell me the information of your computer (CPU & RAM; my CPU is i7-6700 with 16 GB RAM) and platform (OS, mine is Windows 10 x64) that you use to run R/bear? Thanks in advanced and sorry about the error.

» Error in if (Dose <= 0) Dose <- 0 else Dose <- as.numeric(Dose) : missing value, must be TRUE/FALSE

All the best,
---Yung-jin Lee
bear v2.8.3-2:- created by Hsin-ya Lee & Yung-jin Lee
Kaohsiung, Taiwan http://pkpd.kmu.edu.tw/bear
Download link (updated) -> here

Complete thread:

Activity
 Mix view
Bioequivalence and Bioavailability Forum |  Admin contact
19,016 posts in 4,056 threads, 1,297 registered users;
online 19 (1 registered, 18 guests [including 14 identified bots]).

The only people who see the whole picture are the ones
who step out of the frame.    Salman Rushdie

The BIOEQUIVALENCE / BIOAVAILABILITY FORUM is hosted by
BEBAC Ing. Helmut Schütz
HTML5 RSS Feed